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1: Introduction
Hi, and welcome to my guide on editing stuff in Windows! Most of the
stuff in here are simple Windows hacks to edit stuff in your version of
Windows. There will only be a couple of hacks at the moment, but I will
add more as I find them. I hope that you enjoy editing Windows! If you
have any comments, or find a hack for Windows, feel free contact me by
e-mail (http://dansoftaus.uni.cc/aboutus/feedback.htm or
dansoft@dansoftaus.uni.cc) or on MSN (dansoftaus@yahoo.com.au).
NOTE: Most of these hacks are Windows 98-based (since that’s what I
use), but should work on later versions)

2: Utilities Used
The really simple hacks need only the Registry Editor that comes with
Windows (regedit.exe). For more advanced hacks, you need Resource
Hacker, which can actually edit stuff inside executable files (Download
Resource Hacker: http://delphi.icm.edu.pl/ftp/tools/ResHack.zip). Using
Resource Hacker, you can really edit Windows and customise it to your
liking.

3: Using the Registry Editor
The registry editor is really easy to
use, once you get used to it. The
registry is a huge database of all
the settings that Windows needs to
function. It is organised into
‘Keys’, which are like folders that
group items together.  To navigate
through the registry, just double-
click a key to open it, and then
you can browse through the subkeys and values that are in that key. To
change a value, double-click it, and type in the new value. That is all that
you need to know to use the Registry Editor! Now, let’s move on to
Resource Hacker!
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4: Using Resource Hacker
As you can see in the picture, Resource
Hacker is pretty easy to use (unlike
drawing arrows – don’t tease my ability to
draw arrows ;)). All the resources are
grouped into folders, which tell you what
kind of resource it is (eg. Bitmap, Icon,
Menu, Dialog, etc.). Every resource in a
file must have a unique id, which is
usually a number but can be a string (eg.
in the picture there are resource id’s –
143, 149, 150, 151, etc.). Depending on

what kind of resource you click on, the preview window will change
according to that resource. You can also export resources into a file, just
in case you make a mistake. Well, that’s all you need to know about
Resource Hacker.

5: Simple Hacks
Well, I’m gonna begin with some simple hacks. The first one is a most-
requested one, changing the title in Internet Explorer. I will walk you
through this hack, so you can learn what you are doing and how to use the
Registry Editor.

5.1: Internet Explorer Title Change
To start out hacking, we will go into the registry editor. Click
Start –> Run, type ‘regedit’ and click ‘OK’. Once you are in the Registry
editor, you have to navigate to the proper key. Double-click on the
following keys, in order:

HKEY_LOCAL_MACHINE ->
Software ->

Microsoft ->
Internet Explorer ->

Main



Daniel’s Guide for Editing Stuff in Windows

DanSoft Australia – http://dansoftaus.r8.org/

04/04/2004 5:58:49 PM

Page 4 of 10

If you did this correctly, you should have a screen that looks like the
following picture:

If your Registry Editor
looks like this screenshot,
you can continue.
Otherwise, try again, and if
you still can’t figure it out,
please feel free to e-mail
me. Anyways, if there is
already a key called
‘Window Title’ just
double-click it and change
it, otherwise do the
following:

1. Click Edit -> New -> String Value
2. For ‘Name’ type in ‘ Window Title’ and press enter.
3. Double-click the newly-created key, and edit it as you like.
4. The next time you go into Internet Explorer, the new title will appear.

Congratulations! You have finished your
first ‘simple’ hack!

As you can see on the picture opposite, you
can change the heading to anything you
want! This is usually used by ISP’s to
change it to something like ‘Microsoft
Internet Explorer provided by AOL’ or
something similar.

Now, let’s go on to another requested hack

5.2: Changing Windows registered user
What you did for the Internet Explorer hack is basically what you do for
all registry hacks. Now, lets change the Registered User in Windows
(some people want to do this because their name is spelt wrong, or
someone else’s name is there.

Get back into regedit.exe, and go to the following key:
HKEY_LOCAL_MACHINE ->

Software ->
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Microsoft ->
Windows ->

CurrentVersion

This is where most of the settings for your installation of Windows are
kept. There are things such as the ‘Program Files’ path, Product name,
Version, and the thing that we want to change, the Registered user. Now,
to change the registered user, just double-click the ‘RegisteredOwner’
entry and change it to whatever you wish. Simple, eh?

5.3: Others
Here are the locations of some more hacks, although I won’t walk you
through changing them, as you should have already learned by the
previous ones. Note that HKLM stands for HKEY_LOCAL_MACHINE

Change Fonts:
HKLM > Software > Microsoft > Windows > CurrentVersion > Fonts

Programs run at startup:
 HKLM > Software > Microsoft > Windows > CurrentVersion > Run*
(all the keys that start with Run)

Internet Explorer HTML pages:
HKLM > Software > Microsoft > Internet Explorer >AboutURLS

If you search around, you will be able to find things that you wish to edit.

6: More advanced hacks
You can use Resource Hacker to edit the actual Windows files and
change stuff. Let’s look at a simple hack that everyone would want:
editing the picture on the side of the Start Menu.
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6.1: Start menu picture thingy
In case you don’t know what I am talking about, I mean the picture on the
side of the Start Menu, the one that says ‘Windows 98’ sideways on it.
You might think that this is not editable, but you’re wrong!

Start up Resource Hacker, and click File -> Open. Navigate to your
Windows directory (C:\WINDOWS or C:\WINNT) and open
‘EXPLORER.EXE’. Once it has loaded into Resource Hacker, you will
notice that a whole range of resources are in this Windows file. Double-
click the following:
Bitmap ->

157 ->
1033

(Note that this is correct for Windows 98. Other versions might have the
picture in a different Bitmap resource. Just look around)

You should then see your current picture,
as shown to the left. What we want to do
is grab this picture, edit it, and then put it
back. First, right-click the actual picture
and click ‘Copy’. Open your favourite
image editing software (I use Paint Shop
Pro by Jasc Software, use Paint if you
don’t have any image editing software)
and paste it in (Paint Shop Pro: Edit ->

Paste -> As New Image). You can now edit the
picture as much as you want. What I did is put
‘DanSoft Australia’ in it. You can put your name
in it, or completely change it to something else.
See the picture to the right to see what I did.
When you are happy with your image, we need to
save it. Click File -> Save As… and save onto
your desktop as a bitmap file (In Paint Shop Pro it
is ‘Windows or OS/2 Bitmap’). Now, go back to
Resource Hacker, right-click the resource (not the
picture), and click ‘Replace Resource…’
Navigate to the desktop (you can click the
Desktop button ‘ ’) and open the file you
created earlier. Click ‘Replace’. You have now replaced the picture, but
you need to save. Click File -> Save As and save the file in the Windows
directory with a name such as ‘EXPLORE2.EXE’. Since Windows uses
the file, you need to go into DOS Mode to replace it. Start your computer
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in DOS Mode, either by clicking Start -> Shutdown -> Restart in DOS
Mode, boot Disk, holding in CTRL as system starts or pressing F8 at
startup. Go into your Windows directory, rename the EXPLORER.EXE
to something like EXPLORER.OLD and rename the new file to
EXPLORER.EXE. Do something like the following:

CD \WINDOWS
REN EXPLORER.EXE EXPLORER.OLD
REN EXPLORE2.EXE EXPLORER.EXE
EXIT (only if you chose ‘Restart in DOS mode’)

Now, restart your computer to see if it worked. Remember,
if you don’t like it, you can always change it! Well, that’s
it for this hack. Now, let’s move on to a different kind of
hack, dialog boxes.

6.2: The ‘About’ dialog box
This is a different kind of hack, a dialog box hack. We will edit the dialog
that appears when you are in a folder and click Help -> About Windows
98. Most of the windows dialogs are stored in Windows DLL files, so
that more than one program can access them. Open Resource Hacker
again, but this time we will open a different file. Click File -> Open and
navigate to the System directory (C:\WINDOWS\SYSTEM or
C:\WINNT\SYSTEM32) and open ‘SHELL32.DLL’. This file holds most
of the shell stuff, and this includes the dialog we want to edit. If you have
a look around, you will notice that this file has HEAPS of dialog
resources. For now, go to the following resource:
Dialog ->

14352 ->
1033

(you would not believe how long that took me to find. If it is not there,
press CTRL + F and search for ‘user name’)
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Once you are there, you can do whatever you want to the dialog (add
controls, move controls around, etc.). I will show you how to add a text
label to the dialog.
1. Right-click anywhere in the dialog
2. Choose ‘Insert Control’ from the popup menu
3. Click the Label button under ‘Predefined Controls’ or choose

‘STATIC’ from the drop-down box.
4. In ‘Caption’, type in the text that you want the label to show.
5. Click ‘OK’.

You can now move your label around or size it to your liking. When you
have finished your editing, click the ‘Compile Script’ button to actually
build your dialog into the DLL file. Click File -> Save As… and save it as
‘SHELL322.DLL’ or similar. Go back into DOS Mode (however you did
it for the Start Menu pic hack) and type something similar to the
following:

CD \WINDOWS\SYSTEM
REN SHELL32.DLL SHELL32.OLD
REN SHELL322.DLL SHELL32.DLL
EXIT (only if you chose ‘Restart in DOS mode’)

Restart, go into ‘My Computer’ and
click Help -> About. If it worked, you
will be able to see the changes you
made. If you don’t like it, just remove
the change or keep experimenting until
you get what you want. You can even
completely change it around; just keep
playing around with it!
NOTE: If you want to edit the logo, do a
similar thing to what you did for the
Start Menu picture hack, but this time the bitmap is in the file you have
open (SHELL32.DLL), in Resource ID #130 (in Bitmaps). Now let’s
move on to editing the actual items on the Start Menu (I mean the in-built
things like Shut Down)
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6.3: Editing Start Menu Items
Now I’ll show you how to edit items on the Start Menu. Get into
Resource Hacker and open the friendly file EXPLORER.EXE. Navigate
to the resource ‘Menu -> 204 -> 1033’ (this should be the Start Menu, if
it isn’t, search for Shut Down or something similar, don’t even ask about
the ‘Eject PC’ option ;)). Now, find the item that you want to edit in the
script and change it. Example: You want to change ‘Documents’ to ‘My
Stuff’. First, you find the Documents entry in the script:
POPUP "&Documents", 501, MFT_STRING, MFS_ENABLED, 0

And change it to Stuff:
POPUP "S&tuff", 501, MFT_STRING, MFS_ENABLED, 0

If you’re wondering why it’s ‘ S&tuff’ not ‘Stuff’, the ‘&’ puts an
underscore under the ‘t’ and allows you to press ‘t’ when you are in the
Start menu to activate that menu.

When you are finished editing it, click ‘Compile
Script’. To see a preview of your menu, click the ‘ [
]’ button. When you are done, save the file as
‘EXPLORE2.EXE’, go into DOS and follow the
instructions on page 7 about how to put the new file
in place.

6.4: Others
Below are some more hacks to try, although I won’t walk you through
them, as you should already know how to do this by now (note that for
the Notepad hacks, you don’t need to go into DOS mode, just save the
file as ‘NOTEPAD.EXE’)…

Run Dialog: SHELL32.DLL, Dialog > 1003 > 1033
File properties: SHELL32.DLL, Dialog > 1041 > 1033
Shut down dialog: SHELL32.DLL, Dialog > 1064 > 1033
Print Dialog: COMDLG32.DLL, Dialog > 1538 > 1033
Font Dialog: COMDLG32.DLL, Dialog > 1543 > 1033
Open Dialog: COMDLG32.DLL, Dialog > 1547 / 1548 > 1033
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Menus in Notepad: NOTEPAD.EXE, Menu > 1 > 1033
Title of Notepad: NOTEPAD.EXE, String Table > 2 > 1033 (item 19)

You can find many more, especially in SHELL32.DLL (because it is one
of the main files of Windows), just keep looking…

7: The stuff I don’t have to put but I put it
anyway
Well, that’s the end of my tutorial. Since this was my very first tutorial,
please tell me what you think. If you find a really good hack, feel free to
e-mail me (see the email address at the start of this file). Anyway, that’s it
from me, I hope you enjoy hacking Windows!

Daniel Lo Nigro
DanSoft Australia

P.S If you ever want me to write a tutorial on something else, please tell
me!


